System Requirements

Hardware Requirements

A graphics card and driver supporting OpenCL 1.1 or later is required if you wish to make use of Swift’s hardware accelerated solver capabilities. We strongly recommend you have a dedicated graphics card rather than rely on graphics capabilities offered by on-motherboard chips from Intel. If you do rely on integrated graphics, please ensure you are using the latest stable driver available. Alternatively, if graphics hardware is not available on your system, the AMD OpenCL SDK (version 2.9.1 is recommended) provides a software driver that will allow you to operate Swift in a CPU-only manner.

Operating System Requirements


The Windows packages are suitable for Windows XP, Windows 7 or Windows 8. It is recommended that you uninstall the previous version of the software before installing the new version. To install Swift on Windows, simply run the installation executable and follow the on-screen prompts.


Swift is currently supported on Mac OSX 10.7-9 (Lion, Mountain Lion and Mavericks). Support for previous versions of OSX as well as the new Yosemite will be provided in the near future. To install, open the .dmg file, run the installation package inside and follow the on-screen prompts. Swift will then be accessible from within the Applications folder.


All linux packages are built for LSB 4.1 compliant RPM-based systems, the most common of which include SLED13, RHEL and Ubuntu 13.04. To install the packages, make sure the LSB-4.1 packages are installed, then install by using the command (sudo access may be required):

rpm -Ivh <swift package name>.rpm

Swift will then be installed to the /opt/ directory.

For older systems that pre-date LSB 4.1, installation of the RPMs will generally require using the –nodeps option or its equivalent due to the dependency on “lsb>=4.1”. This dependency is there to help package management systems install the packages on which Swift depends. When installing on older systems with the –nodeps option, you are strongly advised to install the most recent lsb package that your distribution/version supports (typically version 3.1).

Installing on Debian-based Systems (e.g. Ubuntu)

To install on Debian-based systems, you will first need to convert the RPM packages into the .deb format using alien. Note that certain options must be used to preserve the pre/post install/uninstall scripts and to prevent the release number from being incremented. The recommended syntax to use is the following:

sudo alien -kcv --bump=0 <swift package name>.rpm

Important: alien does not preserve the dependency on lsb>=4.1, so when installing on systems such as Ubuntu, make sure that the lsb package is indeed installed. Failure to do this can result in issues with misleading error messages.