Skip to main content

System Requirements

Operating System Requirements

Windows

The Windows packages are suitable for Windows XP, Windows 7 or Windows 8. It is recommended that you uninstall the previous version of the software before installing the new version. To install Amicus on Windows, simply run the installation executable and follow the on-screen prompts.

Mac

Amicus is currently supported on Mac OSX 10.9 (Mavericks). Support for previous versions of OSX (Lion, Mountain Lion) as well as the new Yosemite will be provided in the near future. To install, open the .dmg file, run the installation package inside and follow the on-screen prompts. Amicus will then be accessible from within the Applications folder.

Linux

All linux packages are built for LSB 4.1 compliant RPM-based systems, the most common of which include SLED11, RHEL6 and Ubuntu 9.04. To install the packages, make sure the LSB-4.1 packages are installed, then install by using the command (sudo access may be required):

rpm -Ivh <amicus package name>.rpm

Amicus will then be installed to the /opt/csiro.au/Amicus directory.

For older systems that pre-date LSB 4.1, installation of the RPM’s will generally require using the –nodeps option or its equivalent due to the dependency on “lsb>=4.1”. This dependency is there to help package management systems install the packages on which Amicus depends. When installing on older systems with the –nodeps option, you are strongly advised to install the most recent lsb package that your distribution/version supports (typically version 3.1).

Installing on Debian-based Systems (e.g. Ubuntu)

To install on Debian-based systems, you will first need to convert the RPM packages into the .deb format using alien. Note that certain options must be used to preserve the pre/post install/uninstall scripts and to prevent the release number from being incremented. The recommended syntax to use is the following:

sudo alien -kcv --bump=0 <amicus package name>.rpm

Important: alien does not preserve the dependency on lsb>=4.1, so when installing on systems such as Ubuntu, make sure that the lsb package is indeed installed. Failure to do this can result in issues with misleading error messages.