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Introduction 
When you create a TSG dataset, you start out by selecting all spectra that you want to go into 

it.   You can’t add any spectra to the dataset after it has been created1. 

Well, that’s in the past for field-spectrometer datasets as things have changed.   TSG has new 

functionality termed “dynamic import”.   It was motivated by requests for TSG to be more 

supportive of a field-spectrometer workflow. 

Having prepared a starter or “template” dataset with at least one spectrum, some calculated 

scalars and some plots, you can now have TSG watch for new spectra and add them to the 

dataset as they arrive.   Scalars (including TSA or CLS interpretations) are calculated for the 

new arrivals and plots are updated. 

The system is only for field-spectrometer datasets – ones that just have spectra, scalars and 

possibly some sample pictures.   It is not offered for HyLogging datasets as they would require 

more complex data (not just spectra). 

A lightweight version of the system is also available for all spectral datasets, including 

HyLogging ones.   Here, new arrivals are added to the Floater Scratchpad instead of the main 

dataset. 

Quick facts 
 You can add compatible spectra to a plain field-spectrometer TSG dataset 

o Date and (in some cases) GPS scalars are imported too 

o Calculable scalars are calculated;  other scalars get NULL 

o Plots are updated 

 You can add compatible spectra to a Floater Scratchpad 

 Supported import formats are: 

o PANalytical ASD binary files 

o Spectral Evolution OreXpress .SED ASCII files 

o Generic ASCII x,y files 

 The current add methods are: 

o Directory watch 

o Drag & drop 

 Dynamic import settings are remembered for the dataset 

Quick flow 

Dynamic dataset 
1. Prepare a field dataset (optional if you have one already) 

2. Configure the dynamic import 

3. You’re ready.   Start collecting! 

                                                 
1 Yes you could merge TSG datasets but that’s quite a cumbersome process. 



Scratchpad 
1. Open a dataset, then bring up a Floater and put it in Scratchpad mode ( ) 

2. Configure the dynamic import 

3. You’re ready.   Start collecting! 

4. Remember that you have to save the scratchpad manually.   TSG won’t do this 

automatically. 

Preparing a dataset 
This section does not apply to the Scratchpad import.   Also, if you already have a field dataset 

then “dataset creation” doesn’t apply. 

Dataset creation 

Extra space 

When importing ASD, OreXpress or generic ASCII x,y files, you will find a new control in 

page 3 of TSG’s import wizard. 

 

 

 

TSG can now leave empty space in a field dataset.   This setting controls how much extra space 

is allocated, over and above the spectra being imported now.   Enter a number in accord with 

how much dynamic importing you expect to do later. 

Leaving empty space speeds up the process of adding spectra dynamically later on, as the 

dataset is only expanded when it runs out of room.   Dataset expansion is a relatively slow 

process and you wouldn’t want it to happen each and every time a new spectrum was added 

dynamically. 

This setting doesn’t just affect the dataset at the time it is created;  it is also used later.   

Whenever the dataset runs out of room (in the future), it will be expanded by this amount.   

Don’t worry, you can adjust this setting later, as the Dynamic Import Control Panel (see 

below) has the same field (called “File inc” there). 

Extra space remains in the dataset until it is used up by dynamic imports.   If you have “Copy 

.BIP file on open” turned off in File -> Settings [System], you can purge extra space by saving 

the dataset to a different name with File -> Save as… 

Import-time scalars 

If you are importing ASD binary or OreXpress ASCII files then TSG will give you the option 

to import GPS scalars from metadata in the files.   If you know that your files have valid GPS 

metadata then it is useful to import these scalars.   You will find the same GPS option in the 

Dynamic Import Control Panel. 

Date is always imported.   It comes from metadata for ASD and OreXpress formats, and is 

taken from a file’s oldest timestamp for the generic ASCII x,y format. 

Wavelength resampling 

One would normally have the same sort of raw spectrum files (e.g., all ASD binary) at dataset-

creation time and (later) when doing dynamic imports, but this is not a requirement2.   The 

                                                 
2 You can actually mix & match files from different spectrometers but if you do that then please bear in mind the 

differences in actual spectral resolution, reflectance calibration, and noise characteristics. 



important thing to note is that when you do dynamic imports later on, the new files must have 

a wavelength range that is at least as broad as the host dataset’s.   Also, it is best to resample 

the new files in the same way as in the primary import. 

New to this release of TSG is the “Plain L3” resampling algorithm on import.   It’s a 3-lobe 

Lanczos resampling algorithm;  good for general resampling.   Try it.   You will find the same 

option in the Dynamic Import Control Panel. 

Scalars and plots 
Whenever a new spectrum is added to the dataset, calculable scalars will get calculated for it 

and plots will get updated.   Make use of this.   Sure you could have TSG’s Spectrum screen 

open and view the spectrum of each new measurement as it arrives, but TSG has more to offer.   

Here are some simple examples. 

 Have a TSA-mode floater open (see below). 

 Have the Stack screen open. 

 Have the Log screen open, displaying the usual TSA results. 

 Have the Log screen open, displaying some spectral-index and / or User-TSA scalars 

that you have set up.   Perhaps have a floater or two up as well. 

TSA 
TSA scalars will also be recalculated for newly-added spectra.   Any dataset with sufficient 

spectral coverage will have System TSA scalars, and if you set up User TSA scalars then they 

will be calculated too.   If you are working in a well-constrained geological environment then 

we recommend that you set up an environment- or deposit-specific Active-Minerals list for 

your User TSA scalars, then apply this list to new datasets.   This will give you more reliable 

User TSA results. 



Setting up an Active Minerals List 

 

You should come in with a fair idea about what minerals you might expect to find in your 

environment / deposit.   You will need a dataset that contains enough representative spectra to 

judge things by.   Examine the dataset’s System TSA results.   Identify any minerals that TSA 

found but shouldn’t have, and spend some time examining such spectra to check if perhaps 

TSA is actually telling you something that you didn’t know about your environment.   Also 

identify minerals TSA missed but should have found.   Confirm the minerals that TSA rightly 

didn’t find.   Start editing the list once you’re ready. 

 Use TSG’s File -> Settings menu to bring up the Settings dialog. 

 Switch to the TSA tab. 

 If necessary, change the TSA result set selection. 

 Click the Select active minerals button.   You will get another dialog called TSA Item 

Selection.   Use the checkboxes to turn items on and off. 

Once you Proceed out of item selection and OK out of Settings, User TSA scalars will be 

created if necessary, and (re)calculated.   Examine these User TSA results and perhaps do 

another round of list editing. 

Once you have settled on an Active-Minerals list, you should save it to an external file. 

 The TSA Item Selection list has a right-click menu. 

 Right-click on the list and select Save to file… 

 Pick a good filename and subdirectory so that you can find this file easily in the future. 

Applying an Active Minerals List to another dataset 

Say you’re starting another round of sampling and have created a starter / template dataset for 

it.   With this dataset open in TSG: 

 Bring up Settings[TSA] and the TSA Item Selection dialog as described above. 



 Right-click on the list and select Load from file… 

 Load the active-minerals file that you saved earlier. 

Once you Proceed out of item selection and OK out of Settings, suitably-subsetted User TSA 

scalars will be created and calculated. 

CLS scalars 

Advanced TSG users may know about the option to create CLS (Constrained Least Squares) 

unmixing results using TSG’s “Parameter Wizard” (Edit -> New scalar menu).   These scalars 

and their uses are described elsewhere.   In short, the CLS algorithm is simpler and faster than 

TSA.   It copes easily with high mixture levels but very much depends on a tight and sensible 

Restricted Minerals Set being configured by the analyst.   Importantly, CLS scalars work 

through Domain Restricted Minerals Sets.   They do not work through the dataset-global 

Active Minerals List described above.   (The lists look very similar but the mechanism is 

different.)   If you have CLS scalars, you should use TSG’s Domain editor to set up the 

Restricted Minerals Set for the default domain. 

Dynamic Import Control Panel 
This dialog lets you configure the dynamic import.   If you have a dataset open then you can 

bring up the control panel using TSG’s menu: 

File -> Import -> Dynamic import settings… 
If you have an old dataset then you will need to set things here before you can attempt a 

dynamic import.   If your dataset was created by a version of TSG8 from August 2017 or later 

then a number of settings will have been carried over from the import and the drag & drop 

method will be ready to go. 

Some internal settings can’t be established until TSG has seen the first dynamic arrival, so (to 

be sure) TSG pops up the control panel automatically on this occasion. 

 

Select and configure the format of your raw 

spectrum files 

 

Select “watch” method(s) 

 

Configure “watch” directories 

 

Configure spectral resampling;  set the 

increment for when the dataset runs out of 

room 

Dynamic import can add spectra to the main 

dataset or the Floater scratchpad (or even 

both) 

 

Format of incoming raw spectrum files 
TSG currently supports one of three formats here: 

 PANalytical ASD binary files 

 Spectral Evolution OreXpress .SED ASCII files 

 Generic ASCII x,y files 

Select your Format from the list. 



TSG does not expect this to chop and change.   If you want to switch to a different format then 

you should first select and configure it here. 

Click the Configure button to bring up a small control panel with format-specific options.   If 

the main dataset was created with a relatively new build of TSG8 then, as noted earlier, some 

settings will be carried over from the original import. 

 

Configure – ASD binary 

You will find the same options that are in 

the “ASD” page of TSG’s Import wizard. 

 

 

 

 

 Turn on Remove inter-detector steps to have TSG reduce discontinuities at the 

ASD’s detector boundaries (recommended).   The FieldSpec spectrometer has 3 

detectors and it is common to find steps in spectra at the points of change (commonly 

near 1000 and 1830 nm).   A typical reason for this is small differences in surface 

coverage presented to the detectors by the instrument’s optical fibres. 

 Use the Smooth sides options to smooth spectra over the short- and / or long-

wavelength ends of the range.   ASD spectra are often relatively noisy on the sides (e.g., 

350 to ~420 nm and ~2300 to 2500nm).   Factors may include relatively low 

illumination energy, optical throughput, and detector response.   The list lets you select 

a smoothing amount and the two fields let you adjust the smoothing intervals. 

 If you know that your files have valid GPS metadata then turn on Import GPS data 

too to have TSG import the data as Easting, Northing and Depth scalars. 

Halo spectrometer 

The Halo itself deals with the procedure of building up a collection of spectra.   It collects 

a number of binary ASD files, along with a text file that lists the files and has additional 

data (including mineral-match and other calculated scalars).   At a suitable time the 

collection is transferred from the Halo to a PC.   Such a collection and workflow is not a 

good match for TSG’s Dynamic Import functionality.   Use TSG’s normal Halo import 

route instead. 

Configure – OreXpress 

There isn’t much to configure here. 

 At the moment there is only one File format option: 

.SED ASCII files.   Another option may be added in the 

future. 

 OreXpress files may include GPS metadata.   If you 

know that these values are valid then turn on Import GPS data too to have TSG import 

Latitude, Longitude and Altitude scalars.   (Name change pending.) 



Configure – ASCII XY 

 Your files may have one or more “header” lines 

before coming to the columns of x,y, data pairs.   

Open one or two files in a text editor and take a look.   

TSG can’t process header lines.   If you find any, tell 

TSG in the Number of header lines field. 

 Your spectra might have reflectance expressed as 

percent (ranging [0,100]).   TSG wants [0,1].   Open one or two files in a text editor and 

look at the Y (second column) values.   If you see some values that are well over 1.0 

then you probably have percent and should tick the Incoming spectra range 
[0,100] % checkbox. 

New arrivals 
Currently there are two ways in which TSG can “watch” for new spectra to arrive:  Drag & 
drop, and Directory watch.   They apply to the main dataset and floater scratchpad imports.   

You can have one or both “watch” methods active. 

Drag & drop 

There’s no rocket surgery here.   With a dataset open in TSG, drag & drop a file from a 

Windows Explorer window to the main TSG window (main import) or a Floater Scratchpad 

window (scratchpad import). 

 This system only supports one file at a time. 

Directory watch 

Here’s the idea:  Set up your spectrometer’s operating software to save spectra to a certain 

subdirectory as they are measured.   This will be the Watch subdirectory.   Create a separate 

subdirectory for TSG to move spectrum files to, once they have been imported.   This will be 

the Move to subdirectory.   In the Dynamic Import Control Panel, turn on Directory watch 

and configure the subdirectories. 

Here are some rules: 

 The Watch directory is for spectrum files only.   Do not create the dataset there, and do 

not put any other files there.   Also, you must not have any lower-level subdirectories 

in this directory. 

 TSG will check the Watch directory for files every second or two.   As soon as a file 

shows up, TSG will: 

o Move the file to the Move subdirectory. 

 If the file is locked (e.g., still open in some other program) then TSG 

will retry for a few seconds.   If it stays locked or can’t be moved then 

TSG will turn off directory watch. 

 If there already is a file of the given name in the Move subdirectory then 

the old file will be overwritten. 

o Try to import the file. 

 If there was a problem with the import (e.g., it isn’t actually a spectrum 

file) then TSG will change the filename by inserting “xxx” at the start. 

 If two or more files show up together in the Watch directory then TSG will handle each 

file. 



Resample 
If the raw spectrum files do not have exactly the same wavelength spec as the host dataset then 

they will have to be resampled.   Select the resampling algorithm here. 

It is recommended that dynamic imports be resampled with the same method as the spectra in 

the original dataset import.   If the host dataset was created by a recent build of TSG8 then the 

original resampling method will be carried over and shown as the default here. 

File inc 
This is for importing into the main TSG dataset, and is essentially the same field as the one 

described in “Data set creation, Extra space” above.   (See the description there). 

Although dataset expansion is automatic, you wouldn’t want it to happen for each new 

spectrum as it slows things down.   Entering a number greater than 1 will streamline the 

dynamic import process, as new spectra will go into reserved “empty” space when possible and 

the dataset will only get expanded when it runs out of room. 

For general use I’d say set “File inc” to about 1/10 or 1/5 the current dataset size.   Set it to 0 

to let TSG decide (a last resort). 

Active 
 Select Dataset import to have new spectra imported into the main TSG dataset.   (This 

option is greyed out for complex datasets, e.g., HyLogging datasets.) 

 Select Scratchpad import to have new spectra imported into the Floater scratchpad.   

You need to have a floater up and in Scratchpad mode for this to work. 

If you really want to, you can have both of these options active. 


