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What’s new in TSG8, 2 June 2020 
TSG build 8.0.7.1 (and 8.0.7.4 update) 

 
Hello fellow insiders.   TSG build 8.0.7.1 has an updated spectral library for TIR 
unmixing.   There’s also a new splash screen to cheer you up.   Then, some of you will 
be pleased to know that the Chinese core-logger import has been updated to 
produce datasets that are starting to look like HyLogger ones.   Aside from that 
there’s the usual collection of smaller additions and fixes, and at the end is a short 
section about the fixes and changes in the small update release 8.0.7.4.   See the log 
for further details. 
 
 
Important:  TSG build 8.0.7.1 bumps the TSG dataset version.   This means that an 
older TSG will not be able to open any dataset that this release has created or 
modified. 
 
  

https://research.csiro.au/static/tsg/tsglog1620.docx
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TIR unmixing library update 
 
The updated library is known to us as ‘MS9’.   Inside TSG, unmixing results calculated 
from it are reported as version 7.08. 
 
The following spectra were dropped from the previous library (MS8.2a, version 
7.07): 

• Kaolinite-PX  A troublesome spectrum.   No replacements yet. 

• Andalusite  Two new ones measured. 

• Kyanites (2 spectra) New ones measured. 

• Enstatite  New ones measured. 

• Muscovite [double] New ones measured. 

• Biotite   New ones measured. 

• Alunite-K  New ones measured. 
 
The following spectra were added.   There are pyroxenes, sulphates, 
aluminosilicates, micas and a couple of others.   Note that blacklisted spectra are 
shown with a dark grey background in TSG’s selection lists.   They are not included in 
unmixing unless you select them yourself.   Many of the other new spectra are not 
selected by default either, but the blacklisted ones have this extra visual cue. 
 

Mineral Sample number Reason if blacklisted 

Aegirine mes085  

Aegirine mes053  

Alunite-K mes009  

Alunite-K mes0983  

Alunite-K mes008  

Andalusite m2168  

Andalusite m1405  

Augite mt8280  

Augite m1865  

Augite m2222  

Biotite mt8288 Other like it, and big 6500 feature 

Biotite m1592  

Biotite m1589  

Diopside diopside_196  

Diopside m1109  

Diopside 46e654  

Enstatite m2469  

Enstatite mes041  

Hedenbergite m2151  

Hedenbergite nr139 6500nm feature 

Jadeite 143_jadeite  

Jarosite m1234  

Kosmochlor mes081  
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Kyanite mt8362 TSA temp correction -52° 

Kyanite m1352  

Kyanite m2240  

Marialite scapolite_67 Far too easily matched 

Marialite ms81 Not an official sample 

Meionite m1402  

Microcline Oak dam Not an official sample 

Muscovite m2427  

Muscovite Erwan3 Other like it 

Muscovite m1584 Other like it, and weird MIR shape 

Muscovite m2188 Other like it 

Muscovite m1583  

Omphacite mes082  

Petalite m2842  

Petalite m2823  

Pigeonite mt8397  

Phlogopite m1591 Other like it, and 6500 

Phlogopite mes014 Too plain 

Phlogopite m1594  

Phlogopite mes004  

Retsgersite gdd001  

Rhodonite m1094  

Rhodonite broken_hill_rhodonite 6500nm feature 

Sillimanite nr28  

Sillimanite m1391  

Spodumene mes079  

Spodumene m1095  

Spodumene m2408 A slightly weaker version of M1095 

Spodumene m2082  

Wollastonite mt8432  

Wollastonite m2086  

 

Locking TIR unmixing results 
in old datasets 
A change to the unmixing library usually causes a 
change to unmixing results. 
If you have an old dataset with version 7.07 TIR 
unmixing results and would like to prevent these 
results from being recalculated, you can lock the 
results.   (e.g., You might have written a report 
on the dataset.) 
Go into File -> Settings [TSA] and click the button:  
Configure TSA and CLS result lock-down.   Lock 
down the items that you would like to preserve. 
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New splashscreen 

 
The moon is gone! 
Thanks to Jon Huntington for the design, and Luke Macmillan for two of the pictures. 
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Chinese core-logger import 
Given new metadata files, this import can now deliver core-tray reconstructions 
similar to the HyLogger SDF import’s. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The import dialog has five image-processing options like the SDF import’s. 

• Dyna-zoom allows each image frame to be magnified or reduced slightly to 
improve the overlap correlation. 

• Cross-fade conceals overlaps by cross-fading over the overlap region. 

• ‘Albedozer’ is similar to the cross-fade option but only works on albedo 
(brightness), not the full imagery. 

• Tan-theta stretch standardises the pixel size across-scan.   This option 
probably isn’t necessary but it’s there if you’d like to try it. 

• Auto width trim discards excess imagery.   (The camera records far more than 
required across scan.)   Bear in mind, however, that imagery can also be 
trimmed after the import.   (File -> Special -> Linescan width trimming and 
resampling.) 
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Other new functionality and fixes 
 
 

Imports 

HyLogging SDS 

A new diagnostic check has been introduced for the SWIR and TIR FTIR 
spectrometers.   The ‘inspiration’ came from an intermittent SWIR noise problem 
with the NTGS HyLogger-3.   The problem can be detected by a noise estimate 
derived over a tray’s dark calibration, suitably thresholded.   A threshold was found 
for the SWIR spectrometer and set as the default.   No similar noise issues have been 
reported for the TIR spectrometer at this time but the same mechanism was put in 
place for it (with a ‘safe’ default threshold that shouldn’t trigger). 
Settings can be adjusted in the Diag 
sub-dialog that is brought up from the 
HyLogging Diag Mode dialog.   If the check’s Critical checkbox is on then the import 
will stop (with an error message) if a noise problem is detected for a tray.   
Otherwise (Critical off) the HyLogDiag scalar will contain ZS diag codes (or ZT for 
thermal) for noisy trays. 

ASCII XY spectral import 

Spectral Evolution oreXpress .SED 

This import can now handle .sed files where the wavelength column isn’t the first 
one. 

Agilent .ASP 

Each sample’s date is taken from the oldest timestamp (usually the last-modified 
time) of the sample’s .asp file.   There was a time-zone bug in TSG’s handling but it 
has now been fixed. 

General 

I would also like to remind you of quite an old option that can be useful in ASCII 
imports.   In File -> Settings [System] there is an option called Euro-style CSV 
handling.   Normally the comma is used as a delimiter in a CSV file, but in Europe the 
semi-colon is commonly used instead, and the comma is used as the decimal ‘point’ 
in numbers.   As you can imagine, if TSG handles things incorrectly then it’s a bad 
thing. 
Now the reason I’m mentioning this here is because it looks like some instrument 
manufacturers are starting to use this Euro style in their spectrum files if the 
customer’s computer has a certain system setting.   I have seen this in oreXpress and 
Agilent files.   Wrong handling of oreXpress files results in a straight-out failure.   On 
the other hand, Agilent files seem to work but there’s a mysterious and troubling 
loss of precision in the spectra. 



 7 

So if you have problems with ASCII imports, check the files for Euro-style delimiters 
and turn on TSG’s system setting if necessary.   (The system setting also works for 
ASCII XY spectral imports.) 

Binary ASD 

A list of failed files is generated to a file called 00FAILEDIMPORTFILES.txt.   Each line 
includes a failed file’s filename and a brief description of the problem. 
Some analysts import thousands of .ASD files in one go, and until now TSG would 
only report the number of failed files at the end of the import.   Analysts would be 
left searching for the failed files and wondering why they failed. 
The most common cause of failure I’ve seen so far is ‘Different to the other files in 
this collection: datatype’.   I’ve seen this in collections of reflectance spectra that 
included a handful of DN spectra (an instrument handling issue). 

ENVI 

The ‘.raw’ data-file extension is used for SpecIM files sometimes, and TSG wasn't 
recognising it.   It’s recognised now. 

Picture import for field datasets 

The dialog’s Dup (duplicate picture) function only worked up to a point.   Also, 
imported GPS scalars were not being finalised and were not saved persistently.   
These bugs have been fixed. 

Assay CSV import (scalars) 

The handling of embedded quotes has received some attention. 
For example, say the assay table has a comment column and one of the comments 
is:  This item includes "embedded" quotes.   When exported from Excel to 
the clipboard it looks unchanged, but when exported to a csv file it looks like:  "This 
item includes ""embedded"" quotes".   TSG should now handle both cases 
but the file route is recommended. 

General, spectral resampling 

The Plain L3 algorithm has been tweaked slightly.   Also, the Bandpass method’s 
gaussian ‘footprint’ has been widened and should deliver slightly better results from 
very sparse input channels (e.g., at the long end of the wavelength range of an FTIR 
spectrometer). 
 

Scatter screen 
There’s a new option called Copy current sub.   You’ll find it in the right-click menu 
just below the Move current sub option.   It brings up the same sub-dialog as the 
Move current sub option, but instead of swapping the two subscreens’ places it 
nukes the target subscreen.   The target subscreen becomes a carbon copy of the 
current one. 
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It’s handy for when you want to set up a series of subscreens that are mostly alike 
exept for say the aux colour scalar.   You can make copies and then do the necessary 
adjustments. 
 

The rest 

Summary screen, spatial plot 

Sample tracking could come unstuck if the X scalar (normally Depth) was not in sort 
order, and could even cause a crash when combined with a linked spectrum-mode 
floater.   The issue has been fixed.   Also, the bin-size logic was reworked to be more 
accommodating to small datasets, when the Index scalar is used for X. 
 

External unmixing 

CLS algorithm 

Group names were wrong (but okay for the TSA algorithm). 
Some recalc invocations (e.g., the Domain editors Recalc button) didn’t update the 
CLS class tables and this could lead to jumbled results under the ‘right’ 
circumstances. 

TSA algorithm 

User TSA algorithm settings are now used for external TSA unmixing.   So if you 
would like to adjust the aspectral threshold (say) for external TSA then make your 
adjustment via File -> Settings [TSA], for the corresponding library (e.g., the SWIR 
library for an external SWIR-compatible library).   Important: This must be done 
before attaching the external library.   If the library is already attached then detach 
and re-attach after changing settings, or close and re-open the dataset after 
changing settings. 

Mid infrared (MIR) 

I hesitate to mention that TSG now includes very early support for MIR unmixing 
with an external library.   It still has a long way to go before it can be called even half 
reliable, however. 
 

Sorted datasets 

Here I mean datasets that have been sorted on one or two scalars using the Log 
screen’s sorting options. 

Domain editor 

Domain editing is not allowed on sorted datasets but there used to be a couple of 
back doors.   Checking has now been tightened up. 

Tray screen 
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The Tray screen has always presented as if the dataset were unsorted, but navigating 
it from a Floater was a journey into the unknown.   This has now been fixed.   The 
interplay between the Tray screen and a Floater works as if the dataset were 
unsorted. 
 

Floater scratchpad 

There was a bug in sample deletion that could result in scrambled sample names.   It 
has been fixed. 
Samples may be reordered in Spectrum and Stack plot modes.   The Floater’s 

previous and next buttons (  ) are enabled for these modes.   You can use the 
buttons to move the currently-selected sample up or down in the list.   This 
reordering is persistent. 
The selection list has received some attention.   It now includes checkboxes.   In the 
Overlay plot mode, you can retain the list-item colours by clicking in the space below 
the list items after making your selection.   You can then see the list-item colours 
relating to the plot colours. 
 

Rockmarks scalar 

Every TSG dataset gets a Rockmarks scalar now, not just HyLogging datasets.   You 
will find it in the Locations scalar folder. 
 

 
 
 
 
 

The Rockmarks editor (Log and Tray screens) offers a new tag type: URL.   You 
should enter the actual URL itself in the Comment area. 
To complement this, the Goto dialog (  toolbar button) has an Open URL button 
that will direct your web browser to a mark’s URL. 
 

Copy processing 

CLS scalars have always been ‘scalars non grata’ to Copy Processing due to the 
complexity that would need to be dealt with.   But perhaps Copy Processing took 
things a little too far up until now.   CLS scalars were utterly banished – even other 
scalars based on them (e.g., class-extraction scalars) were banished too. 
This has been eased up a little.   If the target dataset also has CLS scalars with the 
same names as the template’s, and based on the same system library as the 
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template’s, then the template’s scalars are treated as ‘matched import’ scalars.   This 
means that other scalars based on the CLS scalars can be copy-processed. 
 

Class editors 

There is a new hotkey:  <ALT><SPACEBAR> 
It assigns the current selection to the class item that’s currently selected in the list. 

• Log- and Tray-screen class editors must be in Select mode.   If there is a 
current selection then it is assigned, otherwise the current sample is 
assigned. 

• In the Scatter screen, if the editor is in Lasso mode then any lassoed samples 
are assigned.   If in Class-locked mode, the current sample is assigned.   
Nothing happens in Lookup mode. 

• The Stack-screen editor only works with masks.   Here, the hotkey toggles the 
current sample’s mask state. 

 

Tray pictures 

The handling of View -> Plot format tweaks in tray-picture generation has been 
given a good working over.   You should now have good control over the size of the 
main title, X-axis title and X-axis annotation.   Also, the handling of the top-left and 
top-right icons has been tweaked.   Icons are now magnified as necessary for high-
resolution pictures. 
 

Mouse zoom 

This is the graphics tool with the  toolbar button.   It lets you stretch out a 
rectangle in a plot, and TSG then zooms in to the rectangle. 
It has been tweaked slightly.   If you don’t stretch out a rectangle at all (e.g., you just 
double-click) then the plot gets reset to its full range. 
 

Headless TSG / download service 

TSG can generate two kinds of log files. 
1. When given the /DEBUG command-line switch, TSG generates a numbered 

log file called tsgeol8_xxx.log alongside the TSG executable.   (Right-click your 
TSG desktop icon and select Properties to find out where the executable is.)   
Occasionally I request a user to generate this file and send it to me to 
diagnose TSG startup problems. 

2. When running in headless mode, TSG generates a numbered log file 
alongside the headless script;  named after the script file. 

Now, if you run headless TSG with a script and use the /DEBUG command-line 
option, you will get the log file as in option 2 but it will also include diagnostic 
startup entries. 
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TSG8.0.7.4 Update 
As sometimes happens, some issues were discovered after the formal release so it is 
followed by a small update, and taking advantage of the occasion a couple of minor 
enhancements are included. 

Fixes 
• Headless mode:  A recent change to combined script / diagnostic log handling 

spoiled the normal use of headless scripts. 

• Updating older datasets:  Automatically updating unmixing results in the 
associated dataset on dataset open could crash TSG under certain conditions.   
(This was not a new bug;  it had just gone unnoticed for some time.) 

• Windows XP build (for TSG QC on HyLoggers):   The latest WinXP build of TSG 
required a DLL that XP doesn’t include.   A workaround was found. 

• Floater previous / next navigation:  This was spoiled for the scatter screen, by 
recent work. 

• Scalars-only datasets:  The import wasn't putting the scalars in the usual 
folders.   The Scatter screen wasn't working.   Log-screen sorting wasn't 
working.   (These are not new bugs but they went unnoticed for some time.) 

New functionality / enhancements 
• Database upload:  The warning about missing tray pictures has been 

improved.   The number of missing pictures is now reported. 

• Headless mode, CLIMPORT task:  A new option has been added to import 
each SDS file-set to its own ‘tsgtray’ dataset.   (These single-tray datasets are 
normally generated by TSG QC on a HyLogger.)   The operation can work 
through nested subdirectories. 

• Keyboard accelerators:  <ALT>C was added – copy to clipboard. 
 
 
 
 
 
 

--oOo-- 


