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What’s new in TSG8, 31 July 2019 
TSG build 8.0.5.1 

 

This release is mostly about new support in TSG related to mineral unmixing.   
Custom unmixing has been made more accessible, and chemistry (atomic elements) 
is starting to show a presence.   Aside from that there are some small improvements 

/ changes.   As always, a log of changes is shown in 
https://research.csiro.au/static/tsg/tsglog1619.docx. 
 

 
 

Custom unmixing 
It is now easy to extend one of 
TSG’s built-in unmixing libraries 

with some1 mineral spectra of 
your own and generate unmixing 
results using the combined library.   
The CLS, TSA and jCLST2 unmixing 

algorithms are available, and 
control over the minerals active in 
unmixing is offered by the Domain 

editor. 
Here’s the documentation:  
https://research.csiro.au/static/tsg/tsg_unmixing_with_custom_libraries.pdf  

 
 

  

                                                             
1 Even one or two. 
2 Under the right conditions:  for TIR unmixing on a production dataset pair that has a TIR part and a 
VNIR-SWIR-compatible part. 

https://research.csiro.au/static/tsg/tsglog1619.docx
https://research.csiro.au/static/tsg/tsglog1619.docx
https://research.csiro.au/static/tsg/tsg_unmixing_with_custom_libraries.pdf
https://research.csiro.au/static/tsg/tsg_unmixing_with_custom_libraries.pdf
https://research.csiro.au/static/tsg/tsg_unmixing_with_custom_libraries.pdf
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Chemistry (atomic elements) 
TSG’s central minerals table now includes standard mineral chemistry3 (and density), 
and it’s starting to find its way into some parts of TSG.   For the time being chemistry 
just has limited support in plots and utilities but may play an active role in unmixing 

in the future. 
 

Summary screen 
The Level selection list has a 
new item Element to 

supplement Mineral and Group.   
It is available for all Plot types.   
Select it and the unmixing result will be presented in elements. 
While mineral unmixing weights are relative volume fractions4, relative mass 

fractions are presented for elements. 

Currently the colour scheme used for elemental Spatial and Difference plots is 
compatible with JMOL. 

Element-level plots work much like mineral and group ones but there are a few 
things worth noting. 

• I recommend that you just stick with Histogram total = Weight (menu 
option).   Summary-screen aggregation is convoluted and you won’t get much 

sense out of Count here. 

• Subsetting controls work for element plots with a couple of differences:  The 
‘NULL item’ is never shown and the ‘Map junk items to NULL’ option hides 
the display of hydrogen and oxygen. 

• Importantly, element-level plots are at the mercy of the mineral unmixing 
results5 that they are drawn from.   They are best suited to TIR unmixing.   
Relatively few minerals are active in SWIR unmixing, and translating just 
SWIR-active minerals to elements can give a misleading picture. 

 

                                                             
3 TSG currently supports the natural elements from atomic number 1 (hydrogen) to 92 (uranium). 
4 More truthfully, they are relative surface-area fractions at the first level of assumption and relative 
volume fractions at the second. 
5 And  the mineral formulae – currently only standard ones in TSG’s central table. 

http://jmol.sourceforge.net/
http://jmol.sourceforge.net/
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Creating element scalars 
 Edit -> Scalar sets -> Play out a scalar set into scalars 
The Summary screen translates mineral unmixing 
results to elements on the fly, without making new 

scalars. 
If you would like individual element scalars (one 
scalar per element) for general use in TSG then there 

is a new tool that you can use.   It is called Play out a 
scalar set into scalars and is launched from the Edit -
> Scalar sets menu. 
The top 2/3 of the dialog has a selection list of the 

dataset’s6 scalar sets.   Scalars will be created from 
the one that you select here. 

Side trip - not just element scalars 

I introduced this tool in the context of elements but there’s more to it.   It can also 

‘play out’ an unmixing result into individual group, subgroup or mineral scalars.   As 
part of their workflow, some analysts have been ‘playing out’ unmixing results into 
individual mineral scalars – the hard way.   They have had to run copy-processing 

with a template containing a squad of class-extraction scalars.   Hopefully this task 
will be easier now.   Also, subgroup-level unmixing results have not been exposed in 
TSG until now. 

Continuing 

• The list labelled ‘One scalar per’ lets you select what level of result to play 
out.   The choices are Mineral, Subgroup, Group and Element. 

• The ‘Include virtuals’ checkbox controls whether non-mineral items like 
‘Aspectral’ also get played out.   (It has no effect when playing out elements.)  

• The ‘Only create active scalars’ checkbox governs what happens with items 
that have no valid (non-NULL results)7.   Some analysts just want active 

scalars while others want the complete set for all datasets. 
o If you turn this option off then you’ll most probably get some empty 

(all NULL) scalars. 

o ‘The complete set’ is defined by the selected scalar set’s full unmixing 
library. 

This tool will create a squad of numeric import-type scalars in the same display 
folder as the source set’s scalars.   For example, if you play out the System jCLST set 

then you will find the scalars in the System TIR display folder. 
If a dataset sample has a valid unmixing result then its scalar values will sum to 1.   
For minerals, subgroups and groups the scalar fractions are assumed to be relative 

volume fractions.   For elements the scalar fractions are (converted) relative mass 
fractions. 

                                                             
6 Both datasets in the case of a dataset pair. 
7 For example, if you are playing out mineral scalars and the dataset has no valid alunite results, do 
you still want (all-NULL) alunite scalars?   Or if elements and the dataset has nothing with calcium, do 
you still want a (NULL) calcium scalar? 
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Re-runs 

If you play out a set more than once to the same sort of output (e.g., to mineral 
scalars) then any existing scalars get re-used.   In other words you can update 
played-out scalars if something about the original TSA result set is modified, but you 

have to be quite deliberate about it. 
 
 

 

Other changes to unmixing support 
 

Floater in TSA mode 

Background 

In the last release (April 2019), new support was added for spinning off a copy of a 
normal unmixing result set like ‘system SWIR TSA’ or ‘domained TIR TSA’.   It gives a 
set of scalars that look like normal imports and do not get updated by TSA / CLS 

recalculations.   April’s release notes had a dot point:  ‘Soon to come:  to reassign 
individual samples’ unmixing results using a TSA Floater in ‘multiple result’ sub -
mode.’   Somehow this has turned out to be true. 

The TSA unmixing algorithm computes several unmixing results for a dataset sample.   
The one that’s judged to be the best is taken and saved to scalars.   You never get to 
see any of the alternative results anywhere in TSG except in a Floater.   If you have a 

TSA-mode Floater and enable its ‘Multiple result (overlay) mode’ menu item then 
you can browse the best alternatives.   Up to three results are kept at each mixture 
level. 

Looking at the alternative results, an analyst might sometimes feel that the best one 
wasn’t chosen.   TSA / TSG will have selected one according to the numbers but 
there might be another result (with a higher fit error for example) that makes more 

geological sense. 
The new functionality allows an alternative Floater result to be selected and saved to 
a spun-off scalar set, overwriting the result there. 

What to do 

1. Use the Edit -> Scalar Sets -> Copy a scalar set tool to make a copy of the 

unmixing result set (e.g., user SWIR TSA) that you would like to fine-tune. 
2. Bring up a Floater, put it in TSA mode, and select ‘a compatible’ TSA set for it 

(first items in the floater TSA menu). 

a. TSA sets based on the same library are compatible.   E.g., ‘System 
SWIR’ and ‘user SWIR’ are compatible. 

3. Turn on the Floater’s Multiple result (overlay) mode menu item. 
4. Browse the dataset.   Alternative results for a sample are shown in the 

Floater’s Candidate TSA results list.   The one chosen by TSA / TSG has an 
asterisk on the left.   If you think another result is better: 

a. Select the result you prefer. 
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b. You will find that the Floater has a new menu item called ‘Replace 
result in user set’.   Use it to select the copy that you made in step 1.  

 

Small changes 

Downsampler 

There has been a small change 
that can fall under the banner of 
unmixing support. 

Background 

In page 2 of the Downsampler 
wizard there is a checkbox called 
Consolidate scalar sets.   If you 

leave it on then a special thing 
happens in the Scalars page (which 
is usually page 4).   For a scalar set 

like System SWIR TSA for example, 
the list of ‘scalars’ gets two special 
entries S_SWIR_TSA705_Mineral 

and S_SWIR_TSA705_Group instead of the sixteen scalars in the set.   These entries 
enable the Downsampler to handle the set’s scalars collectively.   Some tasks should 
access all mixture levels in a set, and this is how it’s done.  
One such task is ‘expansion’.   The Downsampler can take a special set entry (or an 

ordinary class scalar) and write ‘expanded’ output for it.   When generating CSV 
output you get one column per class item (one column per mineral for example).   
It’s a useful tabular report for an unmixing result set.   Analysts with large depth -

registered datasets often generate 1-metre-binned reports like this. 
Expansion can be set individually for each set item or class scalar:  Select an entry in 
the Scalar list in the middle of the dialog and then turn on Expanded. 

The change (absolute expanded) 

Until now the Downsampler would always normalise a row of expanded outputs to 
sum to 1.   Although the Absolute button was shown, it changed nothing in 
expansion.   It works now.   If you have both Expanded and Absolute on then you will 

get a raw (not normalised) output table.   This gives a clearer picture of mineral 
content in a 1-metre-binned output for example. 

jCLST 

There have been a couple of small changes to SWIR moderation: 

• SWIR now overrides TIR on Pyrophyllite. 

• SWIR now overrides TIR on alunites at the mineral level. 

Miscellaneous 
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Summary screen 
Aside from the new element-level plots, the Summary screen has received some 
enhancements. 

• The Spatial plot now has sample-level tracking and current-sample markers. 

• You can now do ‘colourbar highlighting’ in Spatial and Difference plots.   Left-

mouse down over a colourbar block will highlight its samples in the plot.  

• The Subset sub-dialog has a new checkbox ‘Maximum col %’ and 
accompanying value field.   It’s best for Spatial and Difference plots.   You can 
use it to exclude ‘big’ things from the plot so that any patterns in the 

surviving ‘small’ things are more evident. 

• The coloured tiles in an Overview plot are rendered more faithfully (tile 
height). 

 

Scatter screen 
This one’s big. 

You can now rotate a histogram subscreen clockwise!   <Right-click> -> Hist extras -> 
rotated clockwise.   Yes!   Depth going vertically down the screen like it’s supposed 
to do. 

 

Tray screen 
An unpleasant glitch has been fixed in the tray-picture-generation tool, which could 
fail unexpectedly for no good reason.   It should be more stable now.  
 

Headless mode 
• The CLIMPORT task has received a major update.   It can now do HyLogger 

SDS and SDF imports in addition to Corescan imports. 

• The UPLOAD task now supports including a dataset’s (presumably modified) 
linescan raster on subsequent uploads, not just the first. 

Documentation has been updated.   

https://research.csiro.au/static/tsg/tsg_headless_reference.pdf  
 

Feature extraction 
• The ‘MinMax’ algorithm has a new parameter in File -> Settings [FeatEx].   

You can now select the spectral layer that drives it.   In the past it was always 
driven by the Reflectance layer but now you can drive it from the second 

derivative layer (for example) if you like. 

• The floater’s FFC (feature frequency chart) mode continues to evolve.   There 
have been some subtle changes to automatic range handling. 

 

https://research.csiro.au/static/tsg/tsg_headless_reference.pdf
https://research.csiro.au/static/tsg/tsg_headless_reference.pdf
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Log screen 
There is a new standard layout option.   <right-click> -> Standard setup -> VNIR, 
SWIR and TIR TSA.   It sets up the Log screen with ‘the best’8 TSA / jCLST result it can 
find for each wavelength interval.   It is active for VNIR-SWIR + TIR dataset pairs. 

 

Stragglers 
• File -> Dataset Info [Description] can now handle both datasets in a pair.   It 

has two radio buttons along the top. 

• When running PLS prediction where some ‘input-side’ scalars were used in 
the calibration, some NULLS are allowed in these scalars in the target dataset. 

• Layout copying – Summary screen X ranges are handled a bit more 
intelligently. 

• The main toolbar has a refresh ( ) button.   It triggers a thorough refresh. 

• The daily licence check can offer to download a new TSG build (if relevant). 
 

 

                                                             
8 Domained / User TSA / jCLST if present, otherwise System. 


